Variable affichée à 0 au lieu de la valeur

Répondre
jbachet
Messages : 5
Enregistré le : mar. févr. 23, 2016 12:26 pm

Variable affichée à 0 au lieu de la valeur

Message par jbachet » ven. juil. 26, 2019 4:38 pm

Bonjour,

j'ai un formulaire de saisie qui, une fois complété entièrement, lance un 2ème formulaire de Debriefing, pour afficher l'ensemble des réponses et quelques nouvelles variables type commentaire.

Sur le formulaire debriefing, je n'arrive pas à afficher la modalité des réponses sélectionnées quand il y a plusieurs réponses possibles.

exemple :
Variable disponible dans le formulaire "1" : Points_forts
avec plusieurs possibilités de choix (max 2 réponses et autre possible)

Dans le formulaire debriefing, je voudrais afficher les modalités sélectionnées, donc j'ai une zone de texte avec ça :

Points forts :
[Points_forts_1]
[Points_forts_2]
[Points_forts_Autre]

mais ça m'affiche ça :
Points forts :
0
0
test autre (cette ligne que si j'ai renseigné quelque chose dans autre)

je ne comprends pas ce qui cloche.

Le nom des variable est bon (récupéré la liste des variable dans l'export excel)

une idée ?

Pour info, j'ai cette version de SphinxiQ2 : 7.4.1.2

K.AMINE
Messages : 101
Enregistré le : ven. févr. 24, 2017 10:37 am
Localisation : Annecy

Re: Variable affichée à 0 au lieu de la valeur

Message par K.AMINE » lun. juil. 29, 2019 7:59 am

Bonjour,

Dans la zone texte, il faudrait plutôt mettre,
[Points_forts(1)]
[Points_forts(2)]
[Points_forts(3)]

Selon le nombre de réponses possible (dans le cas ci-dessous c'est 3 réponses possibles).

Cordialement.

Répondre